← Blog 19. November 2018 · Amazon Web Services · ElasticSearch

AWS ElasticSearch Call to Authorization engine failed

While updating some lambda functions to AWS ElasticSearch Service version 6.3 the following error occurred:

StatusCodeError: 503 -
{
"Message": "Call to Authorization engine failed"
}

The error seems to be caused by the activated IAM Access Control. By adding the following parameter I was able to solve the issue.

retry_on_status=[502, 503, 504]